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INTRODUCTION

This document was created using the Accessible Digital Office Document (ADOD) Project. The
ADOD Project was developed by the Inclusive Design Research Centre, and OCAD University
as part of an Enabling Change Partnership project.

The purpose of this document is to ensure that County of Wellington public documents are
created in a way that allows them to be viewed by assistive devices.

This is a training manual and reference document for staff.
The software described in this manual include:

s Microsoft Office, specifically Word and,
e Adobe Acrobat Professional Version 10 (X)

Sighted people can look at a printed page and easily discern the difference between titles,
subtitles, columns of text, headers, footers, and so on. Visual clues, such as location of the text
on the page, bold text, and large font sizes help them determine the structure of a document
so they can read and navigate it easily.

Unfortunately, assistive technologies such as screen readers can't depend on these visual
clues. They must instead rely on the underlying computer-based information to provide that
same structure.




MICROSOFT OFFICE

Styles

You should attempt to make use of the named styles that are included in Microsoft Office.
Styles make a document easier to navigate for users of assistive technology.

Word includes a number of built-in styles that are always available, some of which are key to
using different Word features. For example, Normal style is the default paragraph style for all
text in your Word document.

Normal is the style on which most other paragraph styles are based. That means if you change
Normal style (such as changing the font style or size), many other styles will automatically
change to match. As you can imagine, this kind of link between styles can be incredibly useful. It
can also be incredibly frustrating if used incorrectly.

Perhaps the most dynamic of the built-in styles are the paragraph styles Heading 1 through
Heading 9.

**For appropriate styles, please refer to the County’s Accessible Communications
Guidelines as well as the Style Guidelines.
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Headings

Documents that are longer than a few paragraphs require structuring to make them easier for
readers to understand. The easiest way to do this is to use “Headings”. Headings create
logical divisions between paragraphs. Headings are structural elements that provide a
meaningful sequence to users of assistive technologies.

Headings can be found under “Styles” in the Home Ribbon in Microsoft Word.
Headings orient a user to a particular section or element.

It is important that you use the numerical order of headings within your document. You can only
have one Heading1; followed by Heading2 etc. You can have multiple Heading2 or Heading3...

To modify a heading:
1. Right click on the style
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To apply a heading:
1. Highlight the text you wish to apply the heading to.
2. Select the appropriate heading from the Styles List.
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Alternate Text

When using images or other graphical objects, such as charts and graphs, it is
important to ensure that the information you intend to convey by the image is also conveyed to
people who cannot see the image. This can be done by adding alternative text to each image.
If an image is too complicated to concisely describe in the alternative text alone (flowcharts,
etc.), you should provide a short text alternative and longer description as well.

Tips for writing alternative text

e Try to answer the question “what information is the image conveying?”

e |f the image does not convey any useful information, leave the alternative text blank
or do not use the image at all.

e [f the image contains meaningful text, ensure all of the text is replicated

e Alternative text should be fairly short, usually a sentence or less. (rule of thumb 40-
60 characters)

e |f more description is required, provide a short description in the alternative text and
more detail in the long description

e Test by having others review the document with images replaced by the alternative
text

To add alternative text to images and graphical objects

1. Right click the object
2. Select Format Picture (or Size)

O\ d9- 0 Gy 47 Vesinivgdon [Compatibilit fade] - Wierasolt o Header & Footer Tools gfPicture Tools
Home Insert Page Layout References Mallings Review View Add-Ins Acrobat Design Format | (7]
G Brightness ~ Jif ¢ i *] |t > = [P ) i . 4o ;
+ Brightness = Jaf Compress Pictures | | l_) . # == Dashes - i L—,J QL\i ‘ N.j \:l ] %] ‘.’.}j ¥l Height: | 1217 -
(D Contrast = g Reset Picture S0 0, Sk £
A ) Shadow | o Picture = Weight » Position Bring to Send to Text Align Group Rotfite Crap ,_—hl, Width: [1.21" =
4%y Recalor Effects ~ 3 Border~ - Front~ Back* Wrapping~ - x
Adjust Shadow Effects Eorder ] Arrange Size B
[L] l‘.....‘E:.......1....‘..2..‘.‘.5:,-1‘...‘4......;...,.‘.g,.,dl...;.‘. f:J
3. Select the Alt Text tab in the Size dialog
(B HM-0 ] lJ@J-L‘;‘I_l Vs frainingdng [Compatibility Mode]  hicasort Ward Header & Footer Tools * Picture Tools
o - e :
" Home Insert Page Layout References Mailings Review View Add-Ins Acrobat Design | Format L]
5 1 i : | gt 3 ] o i R D =T .-
2 Brightness _li(ompress Pictures E ] | = ¥ == Dashes il L—,IJ q\l] [Nj J:—‘J % {_J‘L\. I‘“cllj' ;'.;J Helght: 1217 =
i Contrast = g Reset Ficture | E13 0, | we— = = 1
I Shadow O Picture = yeight ~ Position Bring to Send to Tex‘_t Align  Group Rotate Crop o] Width: |1.217 =
¥ Recolor Effects v 4 Border~ - Front~ Back~+ Wrapping~ ~ - v
Adjust Shadow Effects Barder i Amange Size ==
|‘.‘|...S...‘...|.‘.,..‘;.....‘.}.L.,...,‘...‘...g"...‘,c‘.“h...y.,. EJ

4. Fill in the Alterative Text

5. Close
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Long Descriptions

Long descriptions should be use when text alternatives are insufficient to answer the question
“what information is the image conveying?”.

¢ In some situations, the information being conveyed will be how an image looks. In these
cases, try to describe the image without making too many of your own assumptions.

e One approach is to imagine you are describing the image to a person over the phone.

e Ensure that you provide a concise alternative text to help readers decide if they are
interested in the longer description.




Tables

When using tables, it is important to ensure that they are clear and appropriate structured. This
helps all users to better understand the information in the table and allows assistive
technologies (e.g. screen readers) to provide context so that the information within the table can
be conveyed in a meaningful way.

Tips for tables

Use “real tables” rather than text formatted to look like tables (EnyE9 -V OERSLTE )
using the TAB key or space bar. These will not be recognized by J(’::‘ rli%_‘ ', pgmjﬂ: rj“”"ﬁ""
assistive technology. o [k IM_I e Sipl =
Keep tables simple by avoiding merged cells and dividing i
complex data sets into separate smaller tables, where possible. [ 0 o o [ |
Whenever possible, use just one row of headings. B e
Create a text summary of the essential table contents. Any iE E%g%g%g%gg
abbreviations should be explained in the summary. I o
Table captions or descriptions should answer the question “what # EE}%E%EE%EE
is the table’s purpose and how is it organized?”. : 3 Insert Toble..

Table cells should be marked as table headers when they serve _. d S

as labels to help interpret the other cells in the table. : (3 excel Spreadsheet

Table header cell labels should be concise and clear. : e —

Ensure the table is not “floating” on the page.

To add a table with headings
1. Goto Insert tab

2. Select the Tables icon

3. Select the number of rows and columns you would like your table to have

4, Select the table and a Table Tools menu item should appear

5. Go to menu item Table Tools >Design

6. Inthe Table Style Options section, select the Header Row Check box
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Lists

When you create lists, it is important to format them as “real lists”. Otherwise, assistive
technologies will interpret your list as a series of short separate paragraphs instead of a
coherent list of related items.

To create an ordered or unordered list

1. Go to menu item: Home

2. Inthe Paragraph section, select the Bullets icon for unordered list or select the
Numbering icon for ordered lists

3. To choose a different list format, select the arrow beside the icon

4. Select a format from the format Library that appears in the drop-down menu.
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Page Breaks

The Page Break feature is very important for assistive technology. Whenever you need to start
a new page, select the Page Break feature instead of repeated hard returns (enter key).

Page Breaks can be found under the Insert tab, or for other types of Breaks, click on the Page
Layout tab and choose the down arrow beside Breaks.
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Table of Contents

Creating an index or table of contents to outline office documents can provide a means of
navigating the meaningful sequence of content.

The best way to generate a table of contents is after applying the predefined heading styles,

such as “Heading1” to the headings that you want to include in your table of contents. After you

apply these styles, you can then create a table of contents.

To insert a Table of Contents

Go to menu item: References
In the Table of Contents section, select Table of Contents
Select the style that you want to use

hON~

To update the Table of Contents

1. Select the table
2. Go to menu item: References
3. Inthe Table of Contents section, select the Update Table button
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Titles

In case the document is ever converted into HTML, it should be given a descriptive and
meaningful title.

To change the title of the current document

1. Go to menu item: Office > Prepare > Properties
2. Inthe Document Properties section that appears, select the Title text box
3. Enter the Title

Note: The Title defined in the properties is different than the file name.

Place the cursor in your document where you want to create the table of contents.
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Colour Contrast

The visual presentation of text and images of text should have a contrast ration of at least
4.5:1. To help you determine the contrast, here are some examples on a white background:

e Very good contrast (Foreground=black, Background=white, Ratio=21:1)
e Acceptable contrast (Foreground=#767676, Background=white, Ratio=4.54:1)

e Unacceptable contrast (Foreground=#AAAAAA, Background=white, Ratio=2.32:1)

Colour contrast differs from on screen to printed publications. These resources are for web
colours, of documents that would be viewed on the web only.

In order to determine whether the colours in your document have sufficient contrast, you can
consult an online contrast checker, such as:

e Juicy Studio: Luminosity Color Contrast Ratio Analyzer
e Joe Dolson Color Contrast Spectrum Tester
e Joe Dolson Color Contrast Comparison

Colour should not be used as the only visual means of conveying information, indicating an
action, prompting a response or distinguishing a visual element. In order to spot where colour
might be the only visual means of conveying information, you can create a screenshot of the
document and then view it with an online grey-scale converting tool, such as:

e GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool

Avoid Using Images of Text

Before you use an image to control the presentation of text (e.g. to ensure a certain font or
colour combination), consider whether you can achieve the same result by styling “real text”. If
this is not possible, as with logos containing stylized text, make sure to provide alternative text
for the image following the techniques noted above.
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Write Clearly

By taking the time to design your content in a consistent way, it will be easier to access,
navigate and interpret for all users.

e \Whenever possible , write clearly with short sentences.
e Introduce acronyms and spell out abbreviations.

e Avoid making the document too “busy” by using lots of whitespace and by avoiding too
many different colours, fonts and images.

As per the County’s Accessible Communications Guideline, write for your specific audience.
For general public documents, aim for between a Grade 9 and Grade 12.

To turn on Readability Statistics

1. Select the Office Button

2. Select Word Options

3. Select Proofing

4. Make sure “Show Readability Statistics” is checked

ra) ¥ 7 T —— Uz
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To check your grade level

Rrd e ppaney

" T

1. Select the Review tab
. Select Spelling and Grammar
3. When spell check is complete,
your grade level will pop upin a
dialogue box.

12|



Templates

All office documents start with a template, which can be as simple as a blank standard-sized
page or as complex as a nearly complete document with text, graphics and other content. For
example, a “Meeting Minutes” template might include headings for information relevant to a
business meeting, such as “Actions” above a table with rows to denote time and columns for
actions of the meeting.

Because templates provide the starting-point for so many documents, accessibility is critical. If
you are unsure whether a template is accessible, you should check a sample document
produced when the template is used .

It is possible to create your own accessible templates from scratch in Word 2007. As well, you
can edit and modify the existing pre-packaged templates, ensuring their accessibility as you do
so and saving them as a new template.

To create an accessible template

1. Create a new document (from the default blank template or from one of the pre-
packaged templates)

2. Ensure that you follow the techniques in this document

3. When you are finished you should also check the

accessibility of the document (See Technique 10, below) g @7 " 2 <&@ ¥4
4. Go to menu item: Office > Save As > Word Template [ e | Save a copy of the document o

fiw: Word Document
Save the file as 3 Word Document.

5. Save the template in the Microsoft > Templates folder
6. Inthe File name box, type a name for the template.

| 7 Open

u; -1 Word Template
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. I be used to format future documents.

Template”) may increase the prominence of the = of) Word 97-2003 Document

— - . Ve | Saveac fthe d ent that is full
accessibility status. As well, filling in the text box labelled | * compatile vith Word 312003,
Tags with the term “accessibility” may improve its R swess | adove por
searchability as an accessible file. Y pime | G OpenDocument Ten

i il u_,ﬂ Save the document In the Open Document

7. Select Save

Format,

| (27| Prepare > J PDF or XPS

= Publish a copy of the document as a PDF or

To select an accessible template 1'433 sa 0 | :’i”m
1. Go to menu item: Office > New B mussin > W Spa b
2. Under Templates, select My templates... | .
3. Inthe New document dialog, select your accessible L o
template from the list in the My Templates tab |23 Wora options | X Extword |

4. Select OK

5. A new document based on the template will be displayed. If you have chosen an
accessible template, the document will be accessible at this point. As you add your
content (e.g., text, images, etc.), ensure that you consult the sections that follow
to preserve accessibility.




ADOBE

In the Adobe Acrobat X Pro workflow, all PDF documents start with a source document
created in an office document authoring application, such as Microsoft Word. Because source
documents provide the starting-point for the PDF documents, accessibility is critical.

See above techniques in order to create an accessible source document using Microsoft Office.
For additional information, please contact the Accessibility Clerk for direction.

Test for Accessibility Compliance

The best way to test the accessibility of a document is to attempt to use the document with the
tools that your readers will use. However, even if you don't have a screen reader or other
assistive device, you can use any of the following methods provided by Acrobat 9 Pro for
checking the accessibility of a PDF.

Tags
Creating a tagged document directly from an authoring application is the best way to make

PDFs accessible. However, if a PDF was created without tags, you can add them, using Add
Tags to Document. Often Acrobat tags PDFs when you create them.

Run Accessibility Checks

For a more thorough review of the accessibility compliance of a document, use one of the
accessibility check features available in Acrobat 9 Pro. The Accessibility Quick Check
examines the PDF to see if it has searchable text, document structure tags, and appropriate
security settings to make it accessible. To check for other types of accessibility problems, it is
best to use the Accessibility Full Check.

Logical Reading Order

The order in which elements in a document are read by assistive software is determined by the
reading order. Each section of page content appears as a separate highlighted region and is
numbered according to its placement in the reading order. You can change the reading order of
the highlighted regions without changing the actual appearance of the PDF. For example, by
reordering highlighted regions on the page, you can make a figure and caption read at the
specific point that they are referenced in the text without actually moving the elements on the

page.




Edit and Add Navigational Aids

Document Structure Tags

PDF tags are a mechanism for indicating the organizational structure of documents (e.g.,
headings, paragraphs, sections, tables, and other page elements) without changing the visual
appearance of the PDF. These tags enable use with assistive devices, such as screen readers,
indicate the document reading order and also enable mobile devices to reflow and display the
document on a small screen.

An untagged document does not have structural information, and Acrobat must infer a structure.
This situation often results in page items being read in the wrong order or not at all. For best
results, tag the document when converting it to PDF from the authoring application.

To add tags automatically

1. Go to menu item: Advanced > Accessibility > Add Tags To Document
Note: This command removes any tags that were in the document before the command
was run. If any potential problems were encountered, an Add Tags Report appears in
the navigation pane.

The automatic tagging feature is usually sufficient for most standard layouts, but it sometimes
cannot correctly interpret the structure and reading order of complex page elements (e.g.
closely spaced columns, irregular text alignment, and tables without borders.). If your testing
(see Technique 2) reveals problems, it is necessary to edit and add tags manually using the
following techniques.

To add tags manually

1. Using the TouchUp Reading Order tool, drag within the document pane to select a
region of the page that contains one type of content (e.g. a text block)

2. To add more page content to the current selection, Shift + drag

3. To remove page content from the current selection, Ctrl + drag

4. Select the appropriate button in the TouchUp Reading Order dialog to specify the tag

type

15]



Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation
pane. Each bookmark goes to a different view or page in the document. In Acrobat 9 Pro, you
can use bookmarks to mark a place in the PDF to which you want to return, or to jump to a
destination in the PDF, another document, or a web page.

Bookmarks are generated automatically during PDF creation from the table of contents entries
and headings of documents created in most authoring tools. They are often tagged and can be
used to make edits in the PDF.

To create a bookmark using keyboard shortcuts

Select Ctri+B

Name the bookmark

Click outside the bookmark to deselect it

Navigate to the page that you want to link with the bookmark
Select the newly created bookmark in the Bookmarks panel
In the Options menu, select Set Bookmark Destination

S mio b =

To create a bookmark without keyboard shortcuts

1. Open the page where you want the bookmark to link to

2. To bookmark a single image, click the image and skip to Step 56

3. To bookmark a portion of an image, drag a rectangle around the portion and skip to Step
5

4. To bookmark selected text, select the text

5. Select the Bookmarks button and select the bookmark under which you want to place
the new bookmark

6. Choose New Bookmark from the Options menu

7. Type or edit the name of the new bookmark

To edit a bookmark

1. Select the Bookmarks button

2. Inthe Bookmarks pane, select the bookmark

3. Inthe Options menu, select Rename Bookmark
4. Type the new bookmark name

To change a Bookmarks destination

1. Select the Bookmarks button

2. Inthe Bookmarks pane, select the bookmark

3. In the document pane, move to the location you want to specify as the new destination
Note: If necessary, adjust the view magnification.

4, In the Options menu, select Set Bookmark Destination

To delete a bookmark

1. Select the Bookmarks button
2. Inthe Bookmarks pane, select a bookmark or range of bookmarks
3. Select Delete

It e e e = e =mee—rres O e e
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To create a bookmark hierarchy

1. Select the Bookmarks button
2. Inthe Bookmarks pane, select the bookmark or range of bookmarks you want to nest
3. Drag the icon or icons directly underneath the parent bookmark
Note: The bookmarks are nested, but the actual page remains in its original location in
the document.

To remove bookmarks from a hierarchy

1. Select the Bookmarks button

2. Inthe Bookmarks pane, select the bookmark or range of bookmarks

3. Move the selection by dragging the icons or select Cut from the Options menu, select
the bookmark and select Paste Under Selected Bookmark from the Options menu

e ——
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Text Alternatives for Images and Graphical Objects

When using images or other graphical objects, such as charts and graphs, it is important to
ensure that the information you intend to convey by the image is also conveyed to people who
cannot see the image. This can be accomplished by adding concise alternative text to of each
image. If an image is too complicated to concisely describe in the alternative text alone (artwork,
flowcharts, etc.), provide a short text alternative and a longer description as well.

Tips for writing alternative text
e Try to answer the question "what information is the image conveying?"
= If the image does not convey any useful information, leave the alternative text blank
e If the image contains meaningful text, ensure all of the text is replicated

o Alternative text should be fairly short, usually a sentence or less and rarely more than
two sentences

e |f more description is required (e.g., for a chart or graph), provide a short description in
the alternative text (e.g., a summary of the trend) and more detail in the long description,
see below

o Test by having others review the document with the images replaced by the alternative
text

Tips for writing longer descriptions

e Long descriptions should be used when text alternatives (see above) are insufficient to
answer the question "what information is the image conveying?"

e |In some situations, the information being conveyed will be how an image looks (e.g., an
artwork, architectural detail, etc.). In these cases, try to describe the image without
making too many of your own assumptions.

e One approach is to imagine you are describing the image to a person over the phone

e Ensure that you still provide concise alternative text to help readers decide if they are
interested in the longer description

Alternatively, you can include the same information conveyed by the image within the body of
the document, providing the images as an alternate to the text. In that case, you do not have to
provide alternate text within the image.

2 Only add alternative text to tags that don’t have child tags. Adding alternative text to a parent
tag prevents assistive software from reading any of that tag’s child tags.

To add alternative text to images or graphical objects

1. Go to menu item: View > Navigation Panels > Tags

2. Inthe Tags tab, select the element

3. Right-click* the element and select Properties...

4. Inthe Tag tab, fill in the alternative text in the Alternative Text box
5. Select Close

18]




To add alternative text to figures and tables

1.

Nooh~kwh

Save the document

Note: Changes using this technique cannot be undone, reverting to a saved document
will be the only way to undo a change.

Go to menu item: Advanced > Accessibility > TouchUp Reading Order...

Select the element by drawing a rectangle around the content

In the TouchUp Reading Order dialog, select Figure or Table

Right-click* the element and select Edit Alternate Text...

Enter the alternative text in the Alternate Text box

Select OK




Document Properties

Document Language

In order for assistive technologies (e.g., screen readers) to be able to present your document
accurately, it is important to indicate the natural language of the document. If a different natural
language is used for a paragraph or selected text, this also needs to be clearly indicated.

To change the default language

1. Go to menu item: File > Properties

2. Select the Advanced tab

3. Inthe Reading Options section, select the language from the Language drop-down list
4. Select OK

To apply a language directly to selected element

Go to menu item: View > Navigation Panels > Tags

In the Tags tab, select the element

Right-click* the element and select Properties...

In the Tag tab, select the language from the Language drop-down list
Select Close

S

Document Title

In case the document is ever converted into HTML, it should be given a descriptive and
meaningful title.

To change the title of the current document

1. Go to menu item: File > Properties

2. Select the Description tab

3. Enter a descriptive title in the Title box. It is also helpful to enter descriptive information
in the text boxes that follow (Author, Subject, Keywords or select Additional
Metadata)

4. Select OK

——




Scanned Documents

Scanned documents are particularly difficult for assistive technology. They appear as an image.
Assistive Technology does not read images unless there accompanied by “alt text”. Because a
scanned document may be several pages long, it is impossible to provide adequate "alt text”. It
is important to ensure that you are always starting with a source document that is not scanned.

If you have a scanned document and do not have access to the original source document, in
order to make the document accessible, you must run it through Optical Character Recognition
(OCR).This feature can be found in all Professional versions of Adobe.

OCR will force Adobe to recognize the text. Once OCR has been run, you can manually add
tags and alter the reading order.
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